HDU 5907:Find

Find Q

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 263    Accepted Submission(s): 148

Problem Description
Byteasar is addicted to the English letter ‘q’. Now he comes across a string S consisting of lowercase English letters.He wants to find all the continous substrings of S, which only contain the letter ‘q’. But this string is really really long, so could you please write a program to help him?

 

Input
The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.In each test case, there is a string S, it is guaranteed that S only contains lowercase letters and the length of S is no more than 100000.

 

Output
For each test case, print a line with an integer, denoting the number of continous substrings of S, which only contain the letter ‘q’.

 

Sample Input
2
qoder
quailtyqqq

 

Sample Output
1
7

 

题意:有一个小写字母组成的字符串S,输出S的所有仅包含字母’q’的连续子串的个数。
 
思路:只S中所有的仅包含q的段的长度,每一段能组成这种字串的个数都是一个等差数列的前n项和。

比如qqqaqq 长度3 2 子串个数 = 1+2+3 + 1+2 = 6 + 3 = 9

 

AC代码:

#include <iostream>
#include<algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;
char c[110000];
__int64 getsum(__int64 n)   //等差数列前n项和
{
    if(n%2==0)return n/2*(1+n);
    else return (1+n)/2*n;
}
int main()
{
    int n;
    scanf("%d%*c",&n);
    while(n--)
    {
        __int64 sum=0,s=0;
        gets(c);
        for(__int64 i=0; i<(__int64)strlen(c); i++)
        {
            if(c[i]=='q')s++;
            else
            {
                if(s)sum+=getsum(s);
                s=0;
            }
        }
        printf("%I64d\n",sum+getsum(s));
    }
    return 0;
}

回复 CAISIDUO 哎呀!还是不要说的啦……

4 只已被捕捉

  • CAISIDUO Chrome | 54.0.2810.2 Windows 7

    这是什么鬼 完全看不懂啊!( ´╥ω╥`)

    • 千千 Chrome | 55.0.2853.0 Windows 10/11

      你猜~

      • CAISIDUO Chrome | 54.0.2810.2 Windows 7

        一片看不懂的鹰文和格式有点像js的代码?

        • 千千 Mozilla FireFox | 50.0 Windows 10/11

          是C++啦