UVA 11572:Unique Snowflakes(尺取法)

 
问题描述:

Emily the entrepreneur has a cool business idea: packaging and selling snowflakes. She has devised amachine that captures snowflakes as they fall, and serializes them into a stream of snowflakes that flow,one by one, into a package. Once the package is full, it is closed and shipped to be sold.The marketing motto for the company is “bags of uniqueness.” To live up to the motto, everysnowflake in a package must be different from the others. Unfortunately, this is easier said than done,because in reality, many of the snowflakes flowing through the machine are identical. Emily would liketo know the size of the largest possible package of unique snowflakes that can be created. The machinecan start filling the package at any time, but once it starts, all snowflakes flowing from the machinemust go into the package until the package is completed and sealed. The package can be completedand sealed before all of the snowflakes have flowed out of the machine.

 

Input

The first line of input contains one integer specifying the number of test cases to follow. Each testcase begins with a line containing an integer n, the number of snowflakes processed by the machine.The following n lines each contain an integer (in the range 0 to 109, inclusive) uniquely identifying asnowflake. Two snowflakes are identified by the same integer if and only if they are identical.The input will contain no more than one million total snowflakes.

 

Output

For each test case output a line containing single integer, the maximum number of unique snowflakesthat can be in a package.

 

Sample Input

1
5
1
2
3
2
1

 

Sample Output

3

 

给出一个数字序列,求最长且里面不包含重复元素的连续子序列。

 

AC代码:

#include<iostream>
#include<algorithm>
#include<set>
using namespace std;
int a[1000005];
int main()
{
    int cases,n;
    cin >> cases;
    while(cases--)
    {
        set<int> s;
        cin>> n;
        for(int i=0; i<n; i++)
            cin >> a[i];
        int left=0,right=0,ans=0;
        while(right<n)
        {
            while(right < n && !s.count(a[right]))
                s.insert(a[right++]);
            ans = max(ans, right-left);
            s.erase(a[left++]);
        }
        cout <<ans<< endl;
    }
    return 0;
}

我想对千千说~