POJ 2484:A Funny Game

A Funny Game

 

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5099 Accepted: 3180

Description

Alice and Bob decide to play a funny game. At the beginning of the game they pick n(1 <= n <= 106) coins in a circle, as Figure 1 shows. A move consists in removing one or two adjacent coins, leaving all other coins untouched. At least one coin must be removed. Players alternate moves with Alice starting. The player that removes the last coin wins. (The last player to move wins. If you can’t move, you lose.) 

1704_1 Figure 1
Note: For n > 3, we use c1, c2, …, cn to denote the coins clockwise and if Alice remove c2, then c1 and c3 are NOT adjacent! (Because there is an empty place between c1 and c3.)Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.

 

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (1 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

 

Output

For each test case, if Alice win the game,output “Alice”, otherwise output “Bob”.

 

Sample Input

1
2
3
0

 

Sample Output

Alice
Alice
Bob

 

  题意:有n枚硬币围成一个圈,每个人只能取走连续的一个或者两个硬币,取走的地方为空,Alice为先手,问最终谁会获胜。

 

  当n==1 || n==2时,明显先手必胜。

  当n==3时,明显先手必败。

  由于每次只可取1或2个,而取2个时,2个必须相邻,

  推断有:当n>3时,若n为偶数,先手无论如何取,后手可在先手对称的位置上取同等数量,于是先手必败。

  若n为奇数,先手取1个时,后手可在先手对称的位置上取2个,之后无论先手如何取,后手都可在先手对称的位置上取同等数量,先手必败。

  如果先手一开始取2个时,后手可在先手对称的位置上取1个,之后还剩下偶数个,可如上推出先手必败。故当 n>3时,先手必败。

 

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
int main()
{
    long long int n;
    while(cin>>n&&n)
    {
        if(n<=2)cout<<"Alice"<<endl;
        else cout<<"Bob"<<endl;
    }
    return 0;
}

我想对千千说~