POJ 1364 King (差分约束)

King

 

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13052 Accepted: 4684

 

Description

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: “If my child was a son and if only he was a sound king.” After nine months her child was born, and indeed, she gave birth to a nice son.
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence.The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son’s skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions.After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong.Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, …, aSi+ni} of a sequence S = {a1, a2, …, an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + … + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + … + aSi+ni < ki or aSi + aSi+1 + … + aSi+ni > ki resp.) and declared these constraints as his decisions.After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not.

 

Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king’s decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.

 

Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last “null” block of the input.

 

Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0

 

Sample Output

lamentable kingdom
successful conspiracy

 

题意

假设当前有这样一个序列 S={a1,a2,a3...an} ,现在给出一些不等式,使得 a[i]+a[i+1]+a[i+2]+...+a[i+n]<k[i]a[i]+a[i+1]+a[i+2]+...+a[i+n]>k[i] ,问这样的一个序列是否存在。

 

思路

样例:

1 2 gt 0 (a1+a2+a3>0)
2 2 lt 2 (a2+a3+a4<2)

首先我们可以设 Si=a1+a2+...+ai

根据样例得出 S3−S0>0S0−S3<=−1

同理 S4−S1<2S4−S1<=1

 

于是便有通式:

a b gt c
S[a−1]−S[a+b]<=−c−1

a b lt c
S[a+b]−S[a−1]<=c−1

 

根据差分约束建图,有向边为

gt: <a+b,a−1>=−c−1

lt: <a−1,a+b>=c−1

最终只需要判断一下当前的图中是否存在负环即可。

假如图中存在负环,那么一定在某两个或者多个不等式中存在冲突,也就是这些不等式不可能同时满足,此时满足所有不等式的最小值不可预料。

 

AC 代码

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
using namespace std;
#include<queue>
#include<map>
#define INF (1<<25)
#define MAXN 30100

int n,m;

struct node
{
    int s;
    int t;
    int w;
    void init(int s,int t,int w)
    {
        this->s=s;
        this->t=t;
        this->w=w;
    }
} edge[105];

int d[105];
bool bf()   //bellman_ford 先n^2一次再判断是否还可以继续优化,若可以则存在负环
{
    memset(d,0,sizeof(d));
    for(int i=1; i<=n; i++)
        for(int j=0; j<m; j++)
            if(d[edge[j].s]+edge[j].w<d[edge[j].t])
                d[edge[j].t]=d[edge[j].s]+edge[j].w;
    for(int i=0; i<m; i++)
        if(d[edge[i].s]+edge[i].w<d[edge[i].t])
            return false;
    return true;
}

int main()
{
    while(~scanf("%d",&n)&&n)
    {
        scanf("%d",&m);
        int from,to,val;
        char str[5];
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%s%d",&from,&to,str,&val);
            if(str[0]=='g')
                edge[i].init(from+to,from-1,-val-1);
            else
                edge[i].init(from-1,from+to,val-1);
        }
        printf(!bf()?"successful conspiracy\n":"lamentable kingdom\n");
    }
    return 0;
}

我想对千千说~