HDU 5835:Danganronpa (不明)

Danganronpa

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 315    Accepted Submission(s): 227


Problem Description
Chisa Yukizome works as a teacher in the school. She prepares many gifts, which consist of n kinds with a[i] quantities of each kind, for her students and wants to hold a class meeting. Because of the busy work, she gives her gifts to the monitor, Chiaki Nanami. Due to the strange design of the school, the students’ desks are in a row. Chiaki Nanami wants to arrange gifts like this:1. Each table will be prepared for a mysterious gift and an ordinary gift.

2. In order to reflect the Chisa Yukizome’s generosity, the kinds of the ordinary gift on the adjacent table must be different.

3. There are no limits for the mysterious gift.

4. The gift must be placed continuously.

She wants to know how many students can get gifts in accordance with her idea at most (Suppose the number of students are infinite). As the most important people of her, you are easy to solve it, aren’t you?

 

Input
The first line of input contains an integer T(T10) indicating the number of test cases.Each case contains one integer n. The next line contains n (1n10) numbers: a1,a2,...,an(1ai100000).

 

Output
For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the answer of Chiaki Nanami’s question.

 

Sample Input
1
2
3 2

 

Sample Output
Case #1: 2
题意:给出不同礼物的数量,每个桌上可以放两种礼物,一个普通礼物,一个神秘礼物,但是相邻两桌的普通礼物不能相同,任何礼物都可以当作普通礼物或者神秘礼物,问最多可以布置好多少张桌子。

 

虽然不知道为什么,但是这道题这样就A了。

 

AC代码:
#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
    int t;
    cin>>t;
    for(int p=1; p<=t; p++)
    {
        int n,a;
        cin>>n;
        int sum=0;
        for(int i=0; i<n; i++)
        {
            cin>>a;
            sum+=a;
        }
        cout<<"Case #"<<p<<": "<<sum/2<<endl;
    }
    return 0;
}

注:代码可能会有错误,但是提交A了。


我想对千千说~