POJ 3370:Halloween treats(鸽巢原理)

Halloween treats

 

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8099 Accepted: 2950 Special Judge

 

Description

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year’s experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

 

Input

The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , … , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

The last test case is followed by two zeros.

 

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print “no sweets” instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

 

Sample Input

4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

 

Sample Output

3 5
2 3 4

 

和这道题一样的思路:https://www.dreamwings.cn/poj2356/4053.html

 

AC代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int pri[110000],sum[110000];
int main()
{
    int c,n,a;
    while(~scanf("%d%d",&c,&n)&&(c||n))
    {
        memset(pri,-1,sizeof(pri));
        memset(sum,0,sizeof(sum));
        pri[0]=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a);
            sum[i]=(sum[i-1]+a)%c;
        }
        for(int i=1; i<=n; i++)
        {
            int *temp=pri+sum[i];
            if(*temp==-1)
                *temp=i;
            else
            {
                for(int j=*temp+1; j<=i; j++)
                    printf(j!=i?"%d ":"%d\n",j);
                break;
            }
        }
    }
    return 0;
}

我想对千千说~