POJ 2356:Find a multiple (鸽巢原理)

Find a multiple
 

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7743 Accepted: 3379 Special Judge

 

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

 

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

 

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

 

Sample Input

5
1
2
3
4
1

 

Sample Output

2
2
3

 

题意:给定n个正数,请你从中找出若干个数,其和刚好是n的倍数。

思路:抽屉原理。
sum[0]=0;
sum[i]=(a[1]+a[2]+a[3]…a[i])%n;
如果存在i>0 使得sum[i]=0;则直接输出a[1],a[2],,….a[i]即可满足题意。
如果不存在,考虑sum[ j ]-sum[ i ]=a [ i+1 ],a[ i+2 ]….a[ j ]。
即如果存在sum[ j ]-sum[ i ]==0,则输出 a [ i+1 ],a[ i+2 ]….a[ j ] 即可。
接下来用抽屉原理证明 i , j 必然存在。

抽屉原理:
如果将大于n个数量的物品放入n个抽屉,则必然存在某个抽屉放了大于1个物品。
因为sum [ i ] 的值只能是1,….n-1.sum [ i ]的数量有n个。
所以由抽屉原理可知,必然存在某两个sum [ i ] 值一样。

 

AC代码:

#include <iostream>
#include<cstdio>
#include<string.h>
using namespace std;

int a[15010],sum[15010],ha[11000];
int main()
{
    int n;
    scanf("%d",&n);
    memset(ha,-1,sizeof(ha));
    ha[0]=0;
    for(int i=1; i<=n; i++)
    {
        scanf("%d",a+i);
        sum[i]=(sum[i-1]+a[i])%n;
    }
    for(int i=1; i<=n; i++)
    {
        int *temp=&ha[sum[i]];
        if(*temp==-1)
            *temp=i;
        else
        {
            printf("%d\n",i-*temp);
            for(int j=*temp+1; j<=i; j++)
                printf("%d\n",a[j]);
            break;
        }
    }
    return 0;
}

我想对千千说~